Posted on 2 Comments

Fix msfupdate error in Kali Linux Rolling

Good evening friends. We have seen how to exploit many recent vulnerabilities using Metasploit.  Metasploit is a penetration testing software which is by default installed in Kali Linux. Metasploit releases updates  every Wednesday with the latest exploits. See the video or scroll through for textual how to.

In order to get the latest exploits, we need to regularly update the Metasploit framework by typing command “msfupdate” as shown below.

But in our latest version of Kali Linux, i.e Kali Linux rolling 2016.1, as soon we start Metasploit after updating, we are getting the following error.

Fixing this error is very simple. We just need to install ruby on our system. Type command apt-get install ruby as shown below.

After ruby installation is finished, start Metasploit. It should open successfully as shown below. It is that much simple to fix msfupdate error in Kali Linux. Happy hacking.

2 thoughts on “Fix msfupdate error in Kali Linux Rolling

  1. This really works!!!!!!!!!! 😀

  2. Hope it works…

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.